summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-07-04 14:28:57 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-10 11:22:39 +0200
commiteef1771ede8cf78a4fd21a7565039c528987c667 (patch)
treef0b851d3505c02723ca67a7adeb2fbb291ad2bd0 /dev-ruby/redis/redis-4.1.4.ebuild
parentdev-ruby/redis: enable ruby30, ruby31 (diff)
downloadgentoo-eef1771ede8cf78a4fd21a7565039c528987c667.tar.gz
gentoo-eef1771ede8cf78a4fd21a7565039c528987c667.tar.bz2
gentoo-eef1771ede8cf78a4fd21a7565039c528987c667.zip
dev-ruby/redis: drop 4.1.4
Closes: https://bugs.gentoo.org/841407 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/redis/redis-4.1.4.ebuild')
-rw-r--r--dev-ruby/redis/redis-4.1.4.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ruby/redis/redis-4.1.4.ebuild b/dev-ruby/redis/redis-4.1.4.ebuild
deleted file mode 100644
index 18843a889001..000000000000
--- a/dev-ruby/redis/redis-4.1.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-MY_P="redis-rb-${PV}"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="redis.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby client library for Redis"
-HOMEPAGE="https://github.com/redis/redis-rb"
-SRC_URI="https://github.com/redis/redis-rb/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~arm64"
-IUSE="doc test"
-
-DEPEND="test? ( =dev-db/redis-5* )"
-
-RUBY_S="${MY_P}"
-
-PATCHES=( "${FILESDIR}/${PN}-4.1.4-local-redis-server.patch" )
-
-ruby_add_bdepend "test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- # call me impatient, but this way we don't need netcat
- sed -i \
- -e '/test_subscribe_past_a_timeout/,+18d' \
- test/publish_subscribe_test.rb || die "sed failed"
-
- sed -i -e 's/git ls-files --/echo/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e '/test_connection_timeout/askip "requires network"' test/internals_test.rb || die
-
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- RUBY=${RUBY} TMP=${T} MT_NO_PLUGINS=true emake -j1 all
- einfo "Wait 5 seconds for servers to stop"
- sleep 5
-}