summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rev/rev-0.3.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rev/rev-0.3.2-r1.ebuild')
-rw-r--r--dev-ruby/rev/rev-0.3.2-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/rev/rev-0.3.2-r1.ebuild b/dev-ruby/rev/rev-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..268f2a4192e8
--- /dev/null
+++ b/dev-ruby/rev/rev-0.3.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> does not compile
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Rev is an event library for Ruby, built on the libev event library"
+HOMEPAGE="https://rubygems.org/gems/rev"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-0.1.0"
+
+each_ruby_configure() {
+ ${RUBY} -C ext/rev extconf.rb || die "Unable to configure rev extionsion."
+
+ ${RUBY} -C ext/http11_client extconf.rb || die "Unable to configure http11 extension."
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but these bindings unfortunately rely on
+ # the lazy load of other extensions; see bug #320545.
+ find ext/rev -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined::' || die "--no-undefined removal failed"
+ emake -C ext/rev V=1 || die "Unable to compile rev extension."
+
+ emake -C ext/http11_client V=1 || die "Unable to compile http11 extension."
+}
+
+each_ruby_install() {
+ cp ext/rev/rev_ext$(get_modname) lib || die
+ cp ext/http11_client/http11_client$(get_modname) lib || die
+
+ each_fakegem_install
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die "Unable to install examples."
+}