summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-29 23:38:07 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-30 00:06:46 -0400
commit66599fd154d6da1d1adbee48e1986d9a3a2ef069 (patch)
treebecf215295c64ae160870f72dccb1e5e385aee05 /dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild
parentdev-ruby/rex-zip: drop random bins (diff)
downloadgentoo-66599fd154d6da1d1adbee48e1986d9a3a2ef069.tar.gz
gentoo-66599fd154d6da1d1adbee48e1986d9a3a2ef069.tar.bz2
gentoo-66599fd154d6da1d1adbee48e1986d9a3a2ef069.zip
dev-ruby/rex-powershell: drop random bins
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild')
-rw-r--r--dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild b/dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..ecb4817aad5d
--- /dev/null
+++ b/dev-ruby/rex-powershell/rex-powershell-0.1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating/manipulating Powershell scripts"
+HOMEPAGE="https://rubygems.org/gems/rex-powershell"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+ruby_add_bdepend "dev-ruby/rex-random_identifier
+ dev-ruby/rex-text"