summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-03 08:15:30 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-03 08:30:40 +0200
commit614b15194902c3f283c9f59a63d72584990c9ad0 (patch)
treeb48326c5cf51399ec1159378a2d6265f59f3c4e0 /dev-ruby/rmagick/rmagick-4.1.2.ebuild
parentdev-ruby/asciidoctor: cleanup (diff)
downloadgentoo-614b15194902c3f283c9f59a63d72584990c9ad0.tar.gz
gentoo-614b15194902c3f283c9f59a63d72584990c9ad0.tar.bz2
gentoo-614b15194902c3f283c9f59a63d72584990c9ad0.zip
dev-ruby/rmagick: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rmagick/rmagick-4.1.2.ebuild')
-rw-r--r--dev-ruby/rmagick/rmagick-4.1.2.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-ruby/rmagick/rmagick-4.1.2.ebuild b/dev-ruby/rmagick/rmagick-4.1.2.ebuild
deleted file mode 100644
index 0efd8df2af44..000000000000
--- a/dev-ruby/rmagick/rmagick-4.1.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="rmagick.gemspec"
-
-MY_PV=RMagick_${PV//\./-}
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
-HOMEPAGE="https://github.com/rmagick/rmagick"
-SRC_URI="https://github.com/rmagick/rmagick/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="rmagick-${MY_PV}"
-
-LICENSE="Artistic"
-SLOT="4"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND+=" >=media-gfx/imagemagick-6.9.0:="
-DEPEND+=" test? ( >=media-gfx/imagemagick-6.9.0:=[jpeg,webp] )"
-
-all_ruby_prepare() {
- # Avoid unused dependency on rake-compiler. This also avoids an
- # extra compile during tests.
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' \
- -e '/compile/ s:^:#:' Rakefile || die
- sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Squelch harmless warning about imagemagick installation.
- sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
-
- # Reading PDFs is not allowed by the default Gentoo security policy for imagemagick
- sed -i -e '/can read PDF file/askip "Not allowed by Gentoo security policy"' spec/rmagick/image/read_spec.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/RMagick extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext/RMagick V=1
- cp ext/RMagick/RMagick2$(get_modname) lib/ || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-
- if use doc ; then
- docinto .
- dodoc -r doc
- fi
-}