summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-07-15 05:21:42 +0200
committerHans de Graaff <graaff@gentoo.org>2020-07-15 05:21:42 +0200
commit472d3e2d73b92b14b0634aaf5f29a261a52abde8 (patch)
tree61fd532beea87cde920b3c35346ab87767d2c35b /dev-ruby/rouge/rouge-3.21.0.ebuild
parentdev-ruby/rouge: cleanup (diff)
downloadgentoo-472d3e2d73b92b14b0634aaf5f29a261a52abde8.tar.gz
gentoo-472d3e2d73b92b14b0634aaf5f29a261a52abde8.tar.bz2
gentoo-472d3e2d73b92b14b0634aaf5f29a261a52abde8.zip
dev-ruby/rouge: add 3.21.0
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rouge/rouge-3.21.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.21.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.21.0.ebuild b/dev-ruby/rouge/rouge-3.21.0.ebuild
new file mode 100644
index 000000000000..7e43cc39b023
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
+ test? ( dev-ruby/minitest-power_assert )
+ dev-ruby/yard
+"
+
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+all_ruby_prepare() {
+ rm -f tasks/{check/style,update/changelog}.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\|rubocop\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}