summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-03 08:32:50 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-03 09:05:24 +0100
commit61a83536ae23aa213f3bc96daa3a377832717592 (patch)
tree0976864ba13a8ab843437f6c42ad7de644c9c3d9 /dev-ruby/rouge/rouge-3.26.0.ebuild
parentdev-ruby/rouge: cleanup (diff)
downloadgentoo-61a83536ae23aa213f3bc96daa3a377832717592.tar.gz
gentoo-61a83536ae23aa213f3bc96daa3a377832717592.tar.bz2
gentoo-61a83536ae23aa213f3bc96daa3a377832717592.zip
dev-ruby/rouge: add 3.26.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rouge/rouge-3.26.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.26.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rouge/rouge-3.26.0.ebuild b/dev-ruby/rouge/rouge-3.26.0.ebuild
new file mode 100644
index 000000000000..09b8e1223bae
--- /dev/null
+++ b/dev-ruby/rouge/rouge-3.26.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
+HOMEPAGE="https://github.com/jneen/rouge"
+SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
+ test? ( dev-ruby/minitest-power_assert )
+ dev-ruby/yard
+"
+
+ruby_add_rdepend "dev-ruby/redcarpet"
+
+all_ruby_prepare() {
+ rm -f tasks/{check/style,update/changelog}.rake || die
+
+ sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
+ sed -i -e '/\(changelog\|bundler\|rubocop\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
+}