summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rqrcode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rqrcode')
-rw-r--r--dev-ruby/rqrcode/Manifest2
-rw-r--r--dev-ruby/rqrcode/metadata.xml5
-rw-r--r--dev-ruby/rqrcode/rqrcode-0.4.2-r1.ebuild28
-rw-r--r--dev-ruby/rqrcode/rqrcode-0.6.0.ebuild30
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode/Manifest b/dev-ruby/rqrcode/Manifest
new file mode 100644
index 000000000000..d4579abea272
--- /dev/null
+++ b/dev-ruby/rqrcode/Manifest
@@ -0,0 +1,2 @@
+DIST rqrcode-0.4.2.gem 19968 SHA256 a565d038004c4de57b4f26a20578aa9d570d08d343e71aae8b04dfb9cbe72fa9 SHA512 70c4a30924217d902e3dc620a31a94cbf1c1e217e58213b9fb28e5c0a7500fe89f19d0082e21d2440c844de9248b39dbe020eafb0752d426d7d11f316b4dd88a WHIRLPOOL c8c890caaa0caa5de9fda898ee7cfd0e431bf4cb399a328dcc5570180576b872c8e06fd274fecf59803854303980f03dbf262e3ddc3f1c7245629465df7e6677
+DIST rqrcode-0.6.0.gem 25088 SHA256 8a57b341e4fc148ef105b16a9ad1eea883a40a55dac9949804cd6431119d30f5 SHA512 613f91855696ec8b95b3879f0639cb5057066e21d5d80714b1cb63cd3dfefbb69fe0baa890d269b326c033febbad2e3705b024bd6baaa550e703b6dac09d10c0 WHIRLPOOL 27a5ce83237a2327409da75d73825a3301d8a154aeea9d581648953a9dec4911c306be6ff77d1b22a543b11420c4dbf1f3861cc4747fa7bca2375c4038549593
diff --git a/dev-ruby/rqrcode/metadata.xml b/dev-ruby/rqrcode/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/rqrcode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rqrcode/rqrcode-0.4.2-r1.ebuild b/dev-ruby/rqrcode/rqrcode-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..c58e6de5e522
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-0.4.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="http://whomwah.github.com/rqrcode/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/rqrcode/rqrcode-0.6.0.ebuild b/dev-ruby/rqrcode/rqrcode-0.6.0.ebuild
new file mode 100644
index 000000000000..72f3bc54feaf
--- /dev/null
+++ b/dev-ruby/rqrcode/rqrcode-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="http://whomwah.github.com/rqrcode/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/chunky_png"
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+}