summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-04-23 13:36:33 +0200
committerJeroen Roovers <jer@gentoo.org>2016-04-23 13:37:11 +0200
commit1a99c4c5c192380a6202661a64c9c536a2eaba0b (patch)
tree9089862ee0f2dfcb9fc7297f3bf534f34f24bc53 /dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
parentnet-analyzer/rrdtool: Version bump. (diff)
downloadgentoo-1a99c4c5c192380a6202661a64c9c536a2eaba0b.tar.gz
gentoo-1a99c4c5c192380a6202661a64c9c536a2eaba0b.tar.bz2
gentoo-1a99c4c5c192380a6202661a64c9c536a2eaba0b.zip
net-analyzer/rrdtool-bindings: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild')
-rw-r--r--dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
new file mode 100644
index 000000000000..671e7d2c5471
--- /dev/null
+++ b/dev-ruby/rrdtool-bindings/rrdtool-bindings-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-ng
+
+MY_P=${P/-bindings}
+MY_P=${MY_P/_/-}
+
+DESCRIPTION="Ruby bindings for rrdtool"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${MY_P}.tar.gz"
+RUBY_S="$MY_P"/bindings/ruby
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="graph test"
+REQUIRED_USE="test? ( graph )"
+
+# Block on older versions of rrdtool that install the bindings themselves.
+# requires rrd_xport which requires rrd_graph
+RDEPEND="
+ ~net-analyzer/rrdtool-${PV}[graph=]
+"
+DEPEND="
+ test? ( ~net-analyzer/rrdtool-${PV}[graph] )
+"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.8-graph-ruby.patch
+)
+
+each_ruby_configure() {
+ rm ../../src/rrd_config.h || die
+ touch ../../src/rrd_config.h || die
+
+ ${RUBY} extconf.rb \
+ --with-cflags="${CFLAGS} $(usex graph -DHAVE_RRD_GRAPH -UHAVE_RRD_GRAPH)" || die
+}
+
+each_ruby_compile() {
+ emake V=1 ABS_TOP_SRCDIR="${PWD}/../.."
+}
+
+each_ruby_test() {
+ if use graph; then
+ ${RUBY} -I. test.rb || die
+ fi
+}
+
+all_ruby_install() {
+ dodoc CHANGES README
+}
+
+each_ruby_install() {
+ DESTDIR=${D} emake install
+}