summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-14 09:51:28 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-14 09:52:49 +0100
commitc326b6b1de7ff3b722fa4f83a9c4950adc12ff7d (patch)
tree8e4b02185e700ed88fa3ca50e2765d58a137a2d6 /dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild
parentdev-ruby/rspec-expectations: add ruby24 (diff)
downloadgentoo-c326b6b1de7ff3b722fa4f83a9c4950adc12ff7d.tar.gz
gentoo-c326b6b1de7ff3b722fa4f83a9c4950adc12ff7d.tar.bz2
gentoo-c326b6b1de7ff3b722fa4f83a9c4950adc12ff7d.zip
dev-ruby/rspec-core: add ruby24
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild')
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild b/dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild
new file mode 100644
index 000000000000..1de7d927d05f
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.99.2-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-2.14.0:2
+ >=dev-ruby/rspec-mocks-2.99.0:2
+ )"
+
+# Skip yard for ruby21 for now since we don't support ruby21 eselected
+# yet and we can't bootstrap otherwise.
+USE_RUBY=${USE_RUBY/ruby21 ruby22 ruby23 ruby24/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/aruba/ s:^:#:' -e '/Aruba/,/}/ s:^:#:' spec/spec_helper.rb || die
+ rm spec/command_line/order_spec.rb || die
+
+ # Avoid testing issues with rspec 3 installed
+ sed -i -e '2igem "rspec", "~> 2.0"' bin/rspec || die
+
+ # Remove minor functionality to remain compatible with rake 12
+ sed -i -e '/last_comment/ s:^:#:' lib/rspec/core/rake_task.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+
+ case ${RUBY} in
+ *ruby23)
+ sed -i -e 's/SAFE = 3/SAFE = 1/' spec/support/helper_methods.rb || die
+ ;;
+ *ruby24)
+ sed -i -e 's/SAFE = 3/SAFE = 1/' spec/support/helper_methods.rb || die
+ sed -i -e 's/Fixnum: 4/Integer: 4/' spec/rspec/core/memoized_helpers_spec.rb || die
+ sed -i -e '/warns when HOME env var is not set/,/^ end/ s:^:#:' spec/rspec/core/configuration_options_spec.rb || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-2 'gem "rspec", "~>2.0"'
+}