summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-01-15 07:28:26 +0100
committerHans de Graaff <graaff@gentoo.org>2022-01-15 07:29:12 +0100
commite89e85d0227ef2f90deed79dce8257ffaa314b58 (patch)
tree8d34e7c0baa4597b0fab901f1eed5ba4d12b6cca /dev-ruby/rspec-expectations
parentdev-ruby/htmlentities: stable all arches (diff)
downloadgentoo-e89e85d0227ef2f90deed79dce8257ffaa314b58.tar.gz
gentoo-e89e85d0227ef2f90deed79dce8257ffaa314b58.tar.bz2
gentoo-e89e85d0227ef2f90deed79dce8257ffaa314b58.zip
dev-ruby/rspec-expectations: add 3.10.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.10.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 182e9ff10716..add7b28c5331 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1,3 +1,4 @@
DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc6adf7be6cabad6df6fd16195c71787d73495924233d793633fa041a94d796f63c9ff97c58e6f4a75bdc09dfbe56e770bb6a5c9 SHA512 6042cafe225b2b16df458c7bf69e1694b637afcac6f6195e35a0be199432610457ccaa3e7e4bd114b27a7a6c3d530d94f4c0603c65f469cbadc55bd3f75b6f3a
DIST rspec-expectations-3.10.1-git.tgz 212281 BLAKE2B a1872a7f71c198db1662eca48bcb34c054f05c16193395962cb47a7fa230c2f0f83bedee302a0ab6a81380a361640177ac3370d8829faa6bd362c07e3a551e5e SHA512 35999542bf70ff04a472e50434abb8815cac8bf10b680da458f5e0e6ee290a1a6356a22cc12f0a8a6310cf282bb6cd99f922fcc63a0cf1e252b167e451bcf7d4
+DIST rspec-expectations-3.10.2-git.tgz 213253 BLAKE2B 51c306d34dfd82d551b8390bed9790748f8f62b9f4b5243399486640d04465dc0c33756f7a575e98c8e61310cf6c25b93b4c1102fc1798814d916defb0ad310e SHA512 819f1b9e881a56d5563c9421e3e897726931c3cb27be5554e35f41077656e426cbac1ddced6a6e61ba21faa7c147c239433ddb9d21ae2e88592d91b286c170a7
DIST rspec-expectations-3.9.4-git.tgz 206297 BLAKE2B c5dbebcf7b411c9cb5cd815dc06fb6f455e82181856661110f803b25f3910975f0676f3cf154e93fe771849363593e104e0f2dd298dfd3d8b1dd96a6ff991547 SHA512 bd025b89751b5b8d3c6bd61a90386fc05ca371e04247d93b29334bbb3eceb84bacea3f3846c20f08dbf53f174992b2dc0fe9f2bc449c4591188b5e428b1d8003
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.10.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.10.2.ebuild
new file mode 100644
index 000000000000..89b2242466ee
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.10.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}