summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-05-07 11:28:10 +0200
committerHans de Graaff <graaff@gentoo.org>2017-05-07 11:44:18 +0200
commiteeb21a009bb31d39881979975dc9a5fd9b643a0c (patch)
tree46127c23972a84a9bee599133b9549e2a465c0b7 /dev-ruby/rspec-its
parentdev-ruby/rb-inotify: add ruby24 (diff)
downloadgentoo-eeb21a009bb31d39881979975dc9a5fd9b643a0c.tar.gz
gentoo-eeb21a009bb31d39881979975dc9a5fd9b643a0c.tar.bz2
gentoo-eeb21a009bb31d39881979975dc9a5fd9b643a0c.zip
dev-ruby/rspec-its: add ruby24
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/rspec-its')
-rw-r--r--dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild b/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild
index 695e22135583..45e97645980b 100644
--- a/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild
+++ b/dev-ruby/rspec-its/rspec-its-1.2.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -20,3 +20,11 @@ KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~x86"
IUSE=""
ruby_add_rdepend ">=dev-ruby/rspec-core-3.0.0 >=dev-ruby/rspec-expectations-3.0.0"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby24)
+ sed -i -e 's/Fixnum/Integer/' spec/rspec/its_spec.rb || die
+ ;;
+ esac
+}