summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-27 07:41:33 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-27 07:41:33 +0200
commit47416704e5e7325dc290da3a70cab07b1756ab1e (patch)
treea14ca57682961ebe6665a323847e9f65aa5488b7 /dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
parentdev-ruby/activeldap: add 5.2.4 (diff)
downloadgentoo-47416704e5e7325dc290da3a70cab07b1756ab1e.tar.gz
gentoo-47416704e5e7325dc290da3a70cab07b1756ab1e.tar.bz2
gentoo-47416704e5e7325dc290da3a70cab07b1756ab1e.zip
dev-ruby/rspec-json_expectations: add 2.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild')
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
new file mode 100644
index 000000000000..b95f3edd5c66
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}