summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-07 11:33:20 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-07 14:28:43 +0200
commit420c2164d5522102d61422daf161f3d4041db82d (patch)
tree71badc75368c3184d21259a7661b4bdb20eddff1 /dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
parentdev-ruby/ruby-atk: add 3.3.7 (diff)
downloadgentoo-420c2164d5522102d61422daf161f3d4041db82d.tar.gz
gentoo-420c2164d5522102d61422daf161f3d4041db82d.tar.bz2
gentoo-420c2164d5522102d61422daf161f3d4041db82d.zip
dev-ruby/ruby-gdkpixbuf2: add 3.3.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild')
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
new file mode 100644
index 000000000000..bdf7742116e2
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_NAME="gdk_pixbuf2"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/${RUBY_FAKEGEM_NAME}
+
+DESCRIPTION="Ruby GdkPixbuf2 bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND+=" x11-libs/gtk+:2"
+
+ruby_add_rdepend "
+ ~dev-ruby/ruby-gio2-${PV}
+"
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}