summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2020-02-06 22:29:13 +0900
committerNaohiro Aota <naota@gentoo.org>2020-07-30 16:58:31 +0900
commitc42ac7287f12f7df3dab6441d316de814bdf9087 (patch)
tree70af791030a953e2061c0da87cc564e7e55868d8 /dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild
parentwww-client/vivaldi-snapshot: Version 3.2.1967.38_p1 (diff)
downloadgentoo-c42ac7287f12f7df3dab6441d316de814bdf9087.tar.gz
gentoo-c42ac7287f12f7df3dab6441d316de814bdf9087.tar.bz2
gentoo-c42ac7287f12f7df3dab6441d316de814bdf9087.zip
dev-ruby/ruby-glib2: version bump to 3.4.2
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Naohiro Aota <naota@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild')
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild
new file mode 100644
index 000000000000..297c9e60b4da
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-3.4.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+all_ruby_prepare() {
+ ruby-ng-gnome2_all_ruby_prepare
+
+ # Skip spawn tests since our sandbox also provides items in the
+ # environment and this makes the test fragile.
+ rm -v test/test-spawn.rb || die
+}