summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2020-02-10 18:23:29 +0900
committerNaohiro Aota <naota@gentoo.org>2020-07-30 16:58:39 +0900
commit09b3c1c8d24ca7c7cdc977784e4fb249daa25cab (patch)
tree349b777365a511cd818d03c0ed3793f20be74280 /dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild
parentdev-ruby/ruby-goffice: add new package (diff)
downloadgentoo-09b3c1c8d24ca7c7cdc977784e4fb249daa25cab.tar.gz
gentoo-09b3c1c8d24ca7c7cdc977784e4fb249daa25cab.tar.bz2
gentoo-09b3c1c8d24ca7c7cdc977784e4fb249daa25cab.zip
dev-ruby/ruby-gnumeric: add new package
This is a new dependency of dev-ruby/ruby-gnome2-3.4.1 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Naohiro Aota <naota@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild')
-rw-r--r--dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild b/dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild
new file mode 100644
index 000000000000..5a0437161cc4
--- /dev/null
+++ b/dev-ruby/ruby-gnumeric/ruby-gnumeric-3.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_GNOME2_NEED_VIRTX=yes
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Gnumeric bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" app-office/gnumeric[introspection]"
+RDEPEND+=" app-office/gnumeric[introspection]"
+
+ruby_add_bdepend "~dev-ruby/ruby-goffice-${PV}"
+ruby_add_rdepend "~dev-ruby/ruby-goffice-${PV}"
+
+# Test is currently disabled.
+# https://github.com/ruby-gnome/ruby-gnome/blob/master/gnumeric/test/test-convert.rb#L27
+each_ruby_test() {
+ :
+}