summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-11 15:42:15 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-11 15:47:59 +0200
commit4dc6b2542c2055d6151e1f9a05bcd5cdac80a17d (patch)
tree3f91feacb53f5946315a980e50f10bd337db4447 /dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild
parentdev-ruby/ruby-glib2: add ruby-gnome 3.0.7 (diff)
downloadgentoo-4dc6b2542c2055d6151e1f9a05bcd5cdac80a17d.tar.gz
gentoo-4dc6b2542c2055d6151e1f9a05bcd5cdac80a17d.tar.bz2
gentoo-4dc6b2542c2055d6151e1f9a05bcd5cdac80a17d.zip
dev-ruby/ruby-gobject-introspection: add ruby-gnome 3.0.7
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild
new file mode 100644
index 000000000000..0f03ada174d1
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Avoid test with ruby20+ code.
+ rm -f test/test-repository.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}