summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-21 08:21:19 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-21 08:21:19 +0200
commit828b1df7e97ee6e3c68d76c5cfc335d718d8a66b (patch)
treef863edd81e57131aee9d08f27396eda9b18aed5b /dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild
parentdev-ruby/ruby-oci8: cleanup (diff)
downloadgentoo-828b1df7e97ee6e3c68d76c5cfc335d718d8a66b.tar.gz
gentoo-828b1df7e97ee6e3c68d76c5cfc335d718d8a66b.tar.bz2
gentoo-828b1df7e97ee6e3c68d76c5cfc335d718d8a66b.zip
dev-ruby/ruby-oci8: add untested 2.2.4.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild')
-rw-r--r--dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild b/dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild
new file mode 100644
index 000000000000..e46cef4cfdd8
--- /dev/null
+++ b/dev-ruby/ruby-oci8/ruby-oci8-2.2.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+DESCRIPTION="A Ruby library for Oracle OCI8"
+HOMEPAGE="https://rubygems.org/gems/ruby-oci8/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND+=" dev-db/oracle-instantclient-basic"
+DEPEND+=" dev-db/oracle-instantclient-basic"
+
+EXT_DIR="ext/oci8"
+
+each_ruby_configure() {
+ # configure the native libraries
+ ${RUBY} -C${EXT_DIR} extconf.rb --prefix="${D}/usr" || die "configure failed"
+}
+
+each_ruby_compile() {
+ # compile the native libraries
+ emake -C ${EXT_DIR} V=1 || die "could not compile native library"
+}
+
+each_ruby_install() {
+ # install the native libraries
+ emake -C ${EXT_DIR} install DESTDIR="${D}" || die "could not install native library"
+ # install the gem files
+ each_fakegem_install
+}