summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-30 07:54:22 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-30 07:54:22 +0100
commitcf67e146f11f2c50ec944aa026ff7b14c9e4cbf9 (patch)
tree9174398a05259ea0b63f2024c379ad1dbd388f38 /dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild
parentdev-ruby/ruby-gettext: add 3.1.9 (diff)
downloadgentoo-cf67e146f11f2c50ec944aa026ff7b14c9e4cbf9.tar.gz
gentoo-cf67e146f11f2c50ec944aa026ff7b14c9e4cbf9.tar.bz2
gentoo-cf67e146f11f2c50ec944aa026ff7b14c9e4cbf9.zip
dev-ruby/ruby-ole: add 1.2.12
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild')
-rw-r--r--dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild b/dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild
new file mode 100644
index 000000000000..f95babd098a6
--- /dev/null
+++ b/dev-ruby/ruby-ole/ruby-ole-1.2.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+# Same thing for the docs whose rake target just calls rdoc.
+RUBY_FAKEGEM_RECIPE_DOC=rdoc
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for easy read/write access to OLE compound documents"
+HOMEPAGE="https://github.com/aquasync/ruby-ole"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --pattern='test.*\.rb' test/
+}