summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-31 17:17:07 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-01 07:08:21 +0100
commit7d77b58a972ef45f63dbc86e22a2c83359a7aba4 (patch)
treeb53df6a91eeede63280a5c8a3e26c63597bd1115 /dev-ruby/ruby-prof
parentdev-ruby/ruby-filemagic: cleanup (diff)
downloadgentoo-7d77b58a972ef45f63dbc86e22a2c83359a7aba4.tar.gz
gentoo-7d77b58a972ef45f63dbc86e22a2c83359a7aba4.tar.bz2
gentoo-7d77b58a972ef45f63dbc86e22a2c83359a7aba4.zip
dev-ruby/ruby-prof: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index c68c6d850080..2f622cfe7461 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,2 +1 @@
-DIST ruby-prof-1.4.2.tgz 90386 BLAKE2B 55263f6cd24b18112a917c2b03a57ca91619419244f79b2b06f6d6794f76d9411d4e1b39dbb2e4b7e2ca6cc03b244f529f4b56fec54ef5fda18853ec2ef05fb4 SHA512 e75a8898533dd2ce9098fcf940883e3cbeaeaecdaebe3592ee67321feb4e294e25bdf14ce6cac50fb6d582cd55d33f175929a1d5446a21b74eb86c468e779fc3
DIST ruby-prof-1.4.3.tgz 232032 BLAKE2B 68df149718869afac89b2240263cd3dd48c28b592f32cd7bc8a918b67de7a10abc3a1af04cb00eeaec9e6f7292e5258d22ba8bec0243361289add943535ffe39 SHA512 fd19d97b88b52c07331bf885c69215267eccb3a0519eb3bb6cd6e5907af55ebbace32f3bdef5b1f340bc3c4779666d7f4100878e647fdfde4da3a4df2a946ebe
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild
deleted file mode 100644
index 716e4bf8ce7a..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-
- # Create directory required for the test suite to pass
- mkdir tmp || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ruby_prof
-
- cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
-}