summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-28 07:21:02 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-28 07:21:02 +0200
commitb3bf87e26130ca78ff280d591d86ceb7400a36e9 (patch)
treed803ade555df60db0e1c07dd87b5430832095265 /dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
parentapp-misc/pax-utils: trivial fix for double prefix. ED -> D. (diff)
downloadgentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.tar.gz
gentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.tar.bz2
gentoo-b3bf87e26130ca78ff280d591d86ceb7400a36e9.zip
dev-ruby/ruby-progressbar: add 1.8.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
new file mode 100644
index 000000000000..48eaf0f033cf
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby20)
+ # Skip specs since rspectacular doesn't work with ruby 2.0:
+ # https://github.com/thekompanee/rspectacular/issues/4
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}