summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-02 07:15:47 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-02 07:15:47 +0100
commitc058f4ad4aa5ac6e6cb1d20debd0c098268f8b57 (patch)
treee46fbf5663db62e71302e1b60ff852e0a0fefee2 /dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
parentdev-ruby/timecop: add ruby24 (diff)
downloadgentoo-c058f4ad4aa5ac6e6cb1d20debd0c098268f8b57.tar.gz
gentoo-c058f4ad4aa5ac6e6cb1d20debd0c098268f8b57.tar.bz2
gentoo-c058f4ad4aa5ac6e6cb1d20debd0c098268f8b57.zip
dev-ruby/ruby-progressbar: drop ruby20
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild16
1 files changed, 2 insertions, 14 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
index e3af4e89c226..dc9bee8d5d71 100644
--- a/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+USE_RUBY="ruby21 ruby22 ruby23"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
@@ -27,15 +27,3 @@ all_ruby_prepare() {
sed -i -e '/warning_filter/ s:^:#:' \
spec/spec_helper.rb || die
}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby20)
- # Skip specs since rspectacular doesn't work with ruby 2.0:
- # https://github.com/thekompanee/rspectacular/issues/4
- ;;
- *)
- RSPEC_VERSION=3 ruby-ng_rspec spec || die
- ;;
- esac
-}