summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-09-27 07:09:11 +0200
committerHans de Graaff <graaff@gentoo.org>2017-09-27 07:09:11 +0200
commita621abca450644201ee19cf87d78090b3d4d58f1 (patch)
treea0714d583b039cea09910e64bfc06556633916a3 /dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild
parentdev-ruby/method_source: add 0.9.0 (diff)
downloadgentoo-a621abca450644201ee19cf87d78090b3d4d58f1.tar.gz
gentoo-a621abca450644201ee19cf87d78090b3d4d58f1.tar.bz2
gentoo-a621abca450644201ee19cf87d78090b3d4d58f1.zip
dev-ruby/ruby-progressbar: don't install default binstubs, bug 632080
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild')
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..c18decbf5958
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.8.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+}