summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/ruby-romkan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/ruby-romkan')
-rw-r--r--dev-ruby/ruby-romkan/Manifest1
-rw-r--r--dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch32
-rw-r--r--dev-ruby/ruby-romkan/metadata.xml6
-rw-r--r--dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild35
-rw-r--r--dev-ruby/ruby-romkan/ruby-romkan-0.4-r5.ebuild32
-rw-r--r--dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild32
6 files changed, 138 insertions, 0 deletions
diff --git a/dev-ruby/ruby-romkan/Manifest b/dev-ruby/ruby-romkan/Manifest
new file mode 100644
index 000000000000..9a3a36dbd677
--- /dev/null
+++ b/dev-ruby/ruby-romkan/Manifest
@@ -0,0 +1 @@
+DIST ruby-romkan-0.4.tar.gz 4653 SHA256 e224490fd2841798a93442cb51f8dda42959ac0d05713421b717243ccf910104 SHA512 d4e4089122d643878a0e19852dd650c4d7e35918838edfe4bc210a5d26cc3e55b5be430db4378e75f44a3435331fd4e1155dfc3e1846babb3a1b626dd127eacd WHIRLPOOL 53642f029131b65c1513bbaf075c0aaa621089bc137beb36ce1343bd932ad18543963b0dc78899fa334b5860b0bf6f2a2bd1a1d72d44e7ab81fc49fa7efd27f7
diff --git a/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
new file mode 100644
index 000000000000..4ae355749281
--- /dev/null
+++ b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
@@ -0,0 +1,32 @@
+--- romkan.rb 2002-02-12 02:45:16.000000000 +0100
++++ romkan.rb 2012-06-25 10:15:59.723542130 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # Ruby/Romkan - a Romaji <-> Kana conversion library for Ruby.
+ #
+@@ -209,13 +210,13 @@
+ HEPPAT = HEPBURN.sort {|a, b| b.length <=> a.length }.join "|"
+
+ TO_HEPBURN = (romrom = Hash.new
+- KUNREI.each_with_index {|x, i|
+- romrom[KUNREI[i]] = HEPBURN[i]}
++ KUNREI.each_with_index {|x, j|
++ romrom[KUNREI[j]] = HEPBURN[j]}
+ romrom)
+
+ TO_KUNREI = (romrom = Hash.new
+- HEPBURN.each_with_index {|x, i|
+- romrom[HEPBURN[i]] = KUNREI[i]}
++ HEPBURN.each_with_index {|x, j|
++ romrom[HEPBURN[j]] = KUNREI[j]}
+ romrom)
+
+ # FIXME: ad hod solution
+--- test.rb 2002-02-12 02:45:25.000000000 +0100
++++ test.rb 2012-06-25 10:13:51.832021574 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # ruby -Ke test.rb </dev/null && echo ok
+ #
diff --git a/dev-ruby/ruby-romkan/metadata.xml b/dev-ruby/ruby-romkan/metadata.xml
new file mode 100644
index 000000000000..321f2e91b33e
--- /dev/null
+++ b/dev-ruby/ruby-romkan/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild
new file mode 100644
index 000000000000..7b3e52f8cadc
--- /dev/null
+++ b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+# ruby19 jruby
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="A Romaji <-> Kana conversion library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-romkan/"
+SRC_URI="http://0xcc.net/ruby-romkan/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DOCS="ChangeLog *.rd"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-ruby19.patch"
+}
+
+each_ruby_test() {
+ ${RUBY} -I. -Ke test.rb < /dev/null || die "test failed"
+}
+
+each_ruby_install() {
+ doruby romkan.rb
+}
+
+all_ruby_install() {
+ dodoc ${DOCS}
+}
diff --git a/dev-ruby/ruby-romkan/ruby-romkan-0.4-r5.ebuild b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r5.ebuild
new file mode 100644
index 000000000000..db39e5ac49df
--- /dev/null
+++ b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="A Romaji <-> Kana conversion library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-romkan/"
+SRC_URI="http://0xcc.net/ruby-romkan/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DOCS="ChangeLog *.rd"
+
+RUBY_PATCHES=( "${FILESDIR}/${PN}-ruby19.patch" )
+
+each_ruby_test() {
+ ${RUBY} -I. -Ke test.rb < /dev/null || die "test failed"
+}
+
+each_ruby_install() {
+ doruby romkan.rb
+}
+
+all_ruby_install() {
+ dodoc ${DOCS}
+}
diff --git a/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild
new file mode 100644
index 000000000000..7b7d850d87a9
--- /dev/null
+++ b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng
+
+DESCRIPTION="A Romaji <-> Kana conversion library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-romkan/"
+SRC_URI="http://0xcc.net/ruby-romkan/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DOCS="ChangeLog *.rd"
+
+RUBY_PATCHES=( "${FILESDIR}/${PN}-ruby19.patch" )
+
+each_ruby_test() {
+ ${RUBY} -I. -Ke test.rb < /dev/null || die "test failed"
+}
+
+each_ruby_install() {
+ doruby romkan.rb
+}
+
+all_ruby_install() {
+ dodoc ${DOCS}
+}