summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-22 07:51:57 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-22 09:55:48 +0200
commita4771c65c6b9ea044ec467e65d24b36d439b9bd6 (patch)
tree2f05dff533c6603f5c00d34b391f46a490c24847 /dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild
parentdev-ruby/recog: cleanup (diff)
downloadgentoo-a4771c65c6b9ea044ec467e65d24b36d439b9bd6.tar.gz
gentoo-a4771c65c6b9ea044ec467e65d24b36d439b9bd6.tar.bz2
gentoo-a4771c65c6b9ea044ec467e65d24b36d439b9bd6.zip
dev-ruby/ruby-sdl: avoid QA notice
Remove a duplicate already compressed sample file. Closes: https://bugs.gentoo.org/738502 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild')
-rw-r--r--dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild
index db796f0a03d8..39b94a9ed94b 100644
--- a/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild
+++ b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r3.ebuild
@@ -28,6 +28,11 @@ CDEPEND="
DEPEND="${DEPEND} ${CDEPEND}"
RDEPEND="${RDEPEND} ${CDEPEND}"
+all_ruby_prepare() {
+ # Remove already compressed image
+ rm -f sample/icon.bmp.gz || die
+}
+
each_ruby_configure() {
${RUBY} extconf.rb || die "extconf.rb failed"
}