summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-10 06:55:55 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-10 06:55:55 +0200
commitffbde2aa37e2b64d0b9e8bbf629194e1238e049d (patch)
tree0bf039c6a4799a3f74165d541cd0e789b758ccc9 /dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild
parentdev-ruby/sexp_processor: add 4.16.1 (diff)
downloadgentoo-ffbde2aa37e2b64d0b9e8bbf629194e1238e049d.tar.gz
gentoo-ffbde2aa37e2b64d0b9e8bbf629194e1238e049d.tar.bz2
gentoo-ffbde2aa37e2b64d0b9e8bbf629194e1238e049d.zip
dev-ruby/ruby_parser: add 3.19.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild')
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild
new file mode 100644
index 000000000000..12b223ec4716
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.19.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby"
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.16.0:4"
+
+ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 >=dev-ruby/sexp_processor-4.16.1:4 )"
+
+DEPEND+=" test? ( dev-util/unifdef )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}