summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-10-11 06:53:51 +0200
committerHans de Graaff <graaff@gentoo.org>2016-10-11 07:14:19 +0200
commitd365aafe407943f62c70ac2304ed0d4ae5be567c (patch)
tree2bd13235291ca1772c29acab30d3fc1d4a08a6b8 /dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild
parentdev-ruby/mocha: add 1.2.0 (diff)
downloadgentoo-d365aafe407943f62c70ac2304ed0d4ae5be567c.tar.gz
gentoo-d365aafe407943f62c70ac2304ed0d4ae5be567c.tar.bz2
gentoo-d365aafe407943f62c70ac2304ed0d4ae5be567c.zip
dev-ruby/ruby_parser: add 3.8.3
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild')
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild
new file mode 100644
index 000000000000..e86c54cc51e7
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby"
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.7.0:4
+ !<dev-ruby/ruby_parser-2.3.1-r1"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 )"
+
+DEPEND+=" test? ( dev-util/unifdef )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}