summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/sanitize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/sanitize')
-rw-r--r--dev-ruby/sanitize/Manifest3
-rw-r--r--dev-ruby/sanitize/metadata.xml8
-rw-r--r--dev-ruby/sanitize/sanitize-2.0.6-r1.ebuild31
-rw-r--r--dev-ruby/sanitize/sanitize-2.1.0.ebuild27
-rw-r--r--dev-ruby/sanitize/sanitize-4.0.0-r1.ebuild37
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-ruby/sanitize/Manifest b/dev-ruby/sanitize/Manifest
new file mode 100644
index 000000000000..bd023253b8fc
--- /dev/null
+++ b/dev-ruby/sanitize/Manifest
@@ -0,0 +1,3 @@
+DIST sanitize-2.0.6.tar.gz 78888 SHA256 ecc0526f231d68dd88efd957145f79841f446ba36124e28c91ef275cc88cafb8 SHA512 e086d6963e8506d498266f0642dd70a9151f38760c1cac69cbba08cde9af291989be48770062dfe824be87f59b21f3d8c125579d9db227f8edea0f93a0993893 WHIRLPOOL 6742f6c06f7b1fc750c76c440e6ed6fd0ee384c6b8afefe0cf064d7c4283e4d877ae9347d7fd392cb1cbfc44798d93d0915059d77aacabf3938ec54ed4491d8e
+DIST sanitize-2.1.0.gem 20992 SHA256 c3be075f5b38a1b02404be5778b181e50fba9ab253bac851cb217d9a71375b77 SHA512 29a26e37342a75af2bc7795578edf2c5064263c58d38dfc36e18f1e111271616c026f7d808a05d63185c12f0e52384db84d62bdb796bf1b21d7e902ef0c1d096 WHIRLPOOL f07c3f7c3550b1e47e3189838a8c1c30c7cd856f237dde167516f25e86520fffe7357f87efd4f2fcf03230650fa55da0ff2d7870746c72c9897318f6dc935cc6
+DIST sanitize-4.0.0.tar.gz 1345735 SHA256 d97e4016a187a7c3e509d837e917b879494185bfd39c67aded0f188a86b4bd14 SHA512 9505bdcc47f7042e4bb406622a86d82e723a5fc3913444708cd32a77203837a57e331611f6f5e284ddba1fe516d70a3c7949026e794bebbf019a0e8b698dfc80 WHIRLPOOL f2db11647797f5056d7ed975a4db26d725eca396feecb60d762a4cdde9a3d4bfc7a680b4dbb32087aedf8eb43bfe1769211c4b744c0793c6c9bad206fc2d0748
diff --git a/dev-ruby/sanitize/metadata.xml b/dev-ruby/sanitize/metadata.xml
new file mode 100644
index 000000000000..5f97c0117141
--- /dev/null
+++ b/dev-ruby/sanitize/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rgrove/sanitize</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/sanitize/sanitize-2.0.6-r1.ebuild b/dev-ruby/sanitize/sanitize-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..468cded8e92a
--- /dev/null
+++ b/dev-ruby/sanitize/sanitize-2.0.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize is a whitelist-based HTML sanitizer"
+HOMEPAGE="https://github.com/rgrove/sanitize"
+SRC_URI="https://github.com/rgrove/sanitize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/nokogiri"
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die "sed failed"
+}
diff --git a/dev-ruby/sanitize/sanitize-2.1.0.ebuild b/dev-ruby/sanitize/sanitize-2.1.0.ebuild
new file mode 100644
index 000000000000..aacd07465de5
--- /dev/null
+++ b/dev-ruby/sanitize/sanitize-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize is a whitelist-based HTML sanitizer"
+HOMEPAGE="https://github.com/rgrove/sanitize"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.4.4"
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_sanitize.rb || die
+}
diff --git a/dev-ruby/sanitize/sanitize-4.0.0-r1.ebuild b/dev-ruby/sanitize/sanitize-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..e6e7db8f1e0f
--- /dev/null
+++ b/dev-ruby/sanitize/sanitize-4.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize is a whitelist-based HTML sanitizer"
+HOMEPAGE="https://github.com/rgrove/sanitize"
+SRC_URI="https://github.com/rgrove/sanitize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/crass-1.0.2 =dev-ruby/crass-1.0*
+ >=dev-ruby/nokogiri-1.4.4
+ >=dev-ruby/nokogumbo-1.4.1 =dev-ruby/nokogumbo-1.4*"
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/nokogumbo/ s/1.4.1/~> 1.4.1/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_sanitize.rb || die
+}