summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-02 06:00:40 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-02 06:00:40 +0100
commit8b7451f71e0f7b41c66d7080972a86269f6d24bc (patch)
tree02771412aeb91e7584bc082db9f930e0d58a0979 /dev-ruby/selenium-webdriver
parentdev-ruby/selenium-webdriver: cleanup (diff)
downloadgentoo-8b7451f71e0f7b41c66d7080972a86269f6d24bc.tar.gz
gentoo-8b7451f71e0f7b41c66d7080972a86269f6d24bc.tar.bz2
gentoo-8b7451f71e0f7b41c66d7080972a86269f6d24bc.zip
dev-ruby/selenium-webdriver: add 3.8.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-3.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index 47902390621a..8bc7ee217fdf 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -3,3 +3,4 @@ DIST selenium-webdriver-3.5.1.gem 830464 BLAKE2B 3f84f324e204beef201656e18b34db6
DIST selenium-webdriver-3.5.2.gem 830976 BLAKE2B 04474aaa7a17c40208d4d5c411cb1c94b31a1f12a1ad9dbaee4dcd40944a2a94340641c2a6a12b605ff3a8979ed0e1336a05284d11dc8ce8125831857edeca5d SHA512 c0a8c0e23e4323762d5cad329774337688cc831658de4bb4712f69c2b4c3f0e189fcd0e3576d8132ec9a3fd5c0365ad128bf65061045514b2871a43b30eaeb3a
DIST selenium-webdriver-3.6.0.gem 841216 BLAKE2B 8cfe144b0f3e827c9344977ea44aeb4638cd4a197c0d06bf11aef92545b66af5504ac58e353841bcce3855870b6b042b09c4793d33b9a1d372ccd0a382d30ae3 SHA512 c0cea582314167de0390007fe26d94e7470020bbb999787fa0883eb65a491a6ecfcbfad9938a50cbc415023edf2ee7ee44ba88ea35d22cbe87d0ed435f38fc99
DIST selenium-webdriver-3.7.0.gem 839168 BLAKE2B 0c6940ff2a8197a3166e8f3f7e7b43bc4551b5bb1f8a40a5887ddcfa7efab93faefa9ead632d3973cbd57a65553a9027f83145bbac753b4ef122f792bae569fd SHA512 f15819d7e3a683d101073710876792ec0cca7c28d387bb9d1b19964083a99e276340fbcfedd9b0ca2234c54f7db56d12dc3af2e4eadf8995e1e05f7282169726
+DIST selenium-webdriver-3.8.0.gem 840192 BLAKE2B 3f3871afed9734627757e58a211ad894fd45a49b73208b533fd39e0d99172536e7f2abdfbed1e0589c45aac6a26dd0c1ae0cf8f25053d44082957f7d07591d37 SHA512 c00c44786ecee4c02723b88c9ae5921d6a3f2d4c6c3bd043da1f524692c75a69357b752fc183c7881de0d0a6e6d6ddb03ca31e6a983afacdd06978bdd0797957
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-3.8.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-3.8.0.ebuild
new file mode 100644
index 000000000000..c4c4d1b87cc2
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-3.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ dev-ruby/rubyzip:1"