summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-01 18:50:48 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-01 18:51:20 +0200
commitaca8baf428c5767ca93c8d7e7a9388e15a6e3c22 (patch)
tree14e6ec2e92778d807fec53adb3f5fc092d0359d2 /dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild
parentmail-client/aerc: fix EOF newline (diff)
downloadgentoo-aca8baf428c5767ca93c8d7e7a9388e15a6e3c22.tar.gz
gentoo-aca8baf428c5767ca93c8d7e7a9388e15a6e3c22.tar.bz2
gentoo-aca8baf428c5767ca93c8d7e7a9388e15a6e3c22.zip
dev-ruby/shoulda-matchers: add 4.1.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild')
-rw-r--r--dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild b/dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild
new file mode 100644
index 000000000000..eac1dba89b96
--- /dev/null
+++ b/dev-ruby/shoulda-matchers/shoulda-matchers-4.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="NEWS.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-matchers"
+SRC_URI="https://github.com/thoughtbot/shoulda-matchers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/s.files/,/^ end/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}