summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-01 07:02:33 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-01 07:08:22 +0100
commitc8114be20f923956a9ce69ea77d5c20871cb2bfe (patch)
tree1468e5bf301e2af1d02d84e50fdd4084b9deac20 /dev-ruby/sigar
parentdev-ruby/ruby-shadow: EAPI 8; fix extension install (diff)
downloadgentoo-c8114be20f923956a9ce69ea77d5c20871cb2bfe.tar.gz
gentoo-c8114be20f923956a9ce69ea77d5c20871cb2bfe.tar.bz2
gentoo-c8114be20f923956a9ce69ea77d5c20871cb2bfe.zip
dev-ruby/sigar: EAPI 8; add ruby30; fix extension install
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sigar')
-rw-r--r--dev-ruby/sigar/sigar-0.7.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/sigar/sigar-0.7.3-r1.ebuild b/dev-ruby/sigar/sigar-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..887ece679573
--- /dev/null
+++ b/dev-ruby/sigar/sigar-0.7.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST=""
+RUBY_FAKEGEM_EXTRADOC="README"
+RUBY_FAKEGEM_EXTENSIONS=(bindings/ruby/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="System Information Gatherer And Reporter"
+HOMEPAGE="http://sigar.hyperic.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND+=" || ( <sys-libs/glibc-2.26 net-libs/libtirpc )"
+
+all_ruby_prepare() {
+ sed -i -e '25i$CFLAGS += " -std=gnu89 -I/usr/include/tirpc"' \
+ -e '25i$LDFLAGS += " -ltirpc"' bindings/ruby/extconf.rb || die
+
+ # Fix compatibility with glibc 2.25
+ sed -i -e '26i#include <sys/sysmacros.h>' \
+ -e '27i#include <ctype.h>' bindings/ruby/rbsigar.c src/os/linux/linux_sigar.c || die
+}