summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-27 08:13:38 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-27 08:13:38 +0200
commit898dc13a9337c0945a74fda08f6ce24e1ed12899 (patch)
treead0ffaaff5c9d17165dd4ca6697ed7164dee3bd5 /dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild
parentdev-ruby/dalli: add 2.7.11 (diff)
downloadgentoo-898dc13a9337c0945a74fda08f6ce24e1ed12899.tar.gz
gentoo-898dc13a9337c0945a74fda08f6ce24e1ed12899.tar.bz2
gentoo-898dc13a9337c0945a74fda08f6ce24e1ed12899.zip
dev-ruby/simplecov-html: add 0.12.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild')
-rw-r--r--dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild b/dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild
new file mode 100644
index 000000000000..880e2e67726e
--- /dev/null
+++ b/dev-ruby/simplecov-html/simplecov-html-0.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets public views"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generates a HTML report of your SimpleCov ruby code coverage results"
+HOMEPAGE="https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1-2)"
+IUSE="doc"