summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-08 07:49:52 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-09 07:00:45 +0100
commitfdad7fb37b1198b0df45f0576446c6c69c5e084a (patch)
treeee35c942fb3c2bc15de704bc47fc3dd781c9d7e7 /dev-ruby/simplecov/simplecov-0.11.1.ebuild
parentdev-ruby/simplecov-html: add 0.10.0 (diff)
downloadgentoo-fdad7fb37b1198b0df45f0576446c6c69c5e084a.tar.gz
gentoo-fdad7fb37b1198b0df45f0576446c6c69c5e084a.tar.bz2
gentoo-fdad7fb37b1198b0df45f0576446c6c69c5e084a.zip
dev-ruby/simplecov: add 0.11.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.11.1.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.11.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.11.1.ebuild b/dev-ruby/simplecov/simplecov-0.11.1.ebuild
new file mode 100644
index 000000000000..974bceef0544
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.11.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and automatic merging of coverage across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0
+ dev-ruby/simplecov-html:0.10
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/test-unit:2
+ dev-util/cucumber
+ dev-util/aruba
+ dev-ruby/capybara
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
+
+# ${RUBY} -S cucumber features || die
+}