summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/simplecov
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/simplecov')
-rw-r--r--dev-ruby/simplecov/Manifest3
-rw-r--r--dev-ruby/simplecov/metadata.xml8
-rw-r--r--dev-ruby/simplecov/simplecov-0.8.2.ebuild48
-rw-r--r--dev-ruby/simplecov/simplecov-0.9.0.ebuild48
-rw-r--r--dev-ruby/simplecov/simplecov-0.9.1.ebuild47
5 files changed, 154 insertions, 0 deletions
diff --git a/dev-ruby/simplecov/Manifest b/dev-ruby/simplecov/Manifest
new file mode 100644
index 000000000000..9d229d0eec93
--- /dev/null
+++ b/dev-ruby/simplecov/Manifest
@@ -0,0 +1,3 @@
+DIST simplecov-0.8.2.gem 48128 SHA256 6ef2e7c8d14c931f09ea2542d0bea6281ca766aa229bc68bc7a7d40df9647cf9 SHA512 01ed1bfa587b1c3cc6d62bbde55f0c27dac2f60d43f8b9c8c3737f68c5161e755428dfc2bca44707f84f0ffbf716006c38d63c7a8802e5a0d613c04f0ef591a4 WHIRLPOOL 1c0f9786fb1494db09eb4af20c085b49f9cc5f8fedf025207b080d980a00ee677c31a312a9dcb6dd2eb7f4bf67208ce489b07df01c326a49896ce4c373deb3a8
+DIST simplecov-0.9.0.gem 49664 SHA256 4f205752a4f3730fd4c58678bbab4c83f4e2a6ca3bbea4cdf18cd86a70589eb7 SHA512 4c27e512ca7ad6c63716ca180f56fdb1d004f1b98c33ea23e8a1eb1d0fd8a5462fe3deed0e7607858eb03861c935a281f224995c6df3fbb22a7fca5806960988 WHIRLPOOL e2c22d6224c019a695d9418326d51749cba287e9b9341ff2ceb813da3191d7dab5bb33d8e33d6e2bc8aadabac07d65208eb0d8890ab5c521726016f818764722
+DIST simplecov-0.9.1.gem 49152 SHA256 ce9ffc797f9e4493bf97bbf5e88073ad7351d8234561b56ea3bd2baa68a71e1a SHA512 f988224f28d6fcb58ef609dcb1e74bec37c6fe05787d1e6b4ac58f23e7c6ca9e10aad417b731dfb414f64d6fc4555f1719aebf1e4434130aa45b3650b2a1d9fa WHIRLPOOL 8bbb35d659d2d0a4e0c0657879f5c45d3a989309c8332906737c3015a6d4f8a6858344c63daa5494d51ddf424b5ec09b36035ba2cab1a6324fa56d096b7ad7ab
diff --git a/dev-ruby/simplecov/metadata.xml b/dev-ruby/simplecov/metadata.xml
new file mode 100644
index 000000000000..05cdc6836d96
--- /dev/null
+++ b/dev-ruby/simplecov/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">colszowka/simplecov</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simplecov/simplecov-0.8.2.ebuild b/dev-ruby/simplecov/simplecov-0.8.2.ebuild
new file mode 100644
index 000000000000..3efa133ae9c7
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and automatic merging of coverage across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0
+ >=dev-ruby/lockfile-2.1.0
+ dev-ruby/simplecov-html:0.8
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec
+ dev-ruby/shoulda
+ dev-ruby/test-unit:2
+ dev-util/cucumber
+ dev-util/aruba
+ dev-ruby/capybara
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' test/helper.rb features/support/env.rb || die
+
+ # Avoid currently failing test, needs further research.
+ rm test/test_merge_helpers.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+
+# ${RUBY} -S cucumber features || die
+}
diff --git a/dev-ruby/simplecov/simplecov-0.9.0.ebuild b/dev-ruby/simplecov/simplecov-0.9.0.ebuild
new file mode 100644
index 000000000000..3efa133ae9c7
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and automatic merging of coverage across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0
+ >=dev-ruby/lockfile-2.1.0
+ dev-ruby/simplecov-html:0.8
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec
+ dev-ruby/shoulda
+ dev-ruby/test-unit:2
+ dev-util/cucumber
+ dev-util/aruba
+ dev-ruby/capybara
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' test/helper.rb features/support/env.rb || die
+
+ # Avoid currently failing test, needs further research.
+ rm test/test_merge_helpers.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+
+# ${RUBY} -S cucumber features || die
+}
diff --git a/dev-ruby/simplecov/simplecov-0.9.1.ebuild b/dev-ruby/simplecov/simplecov-0.9.1.ebuild
new file mode 100644
index 000000000000..99fa1c70c478
--- /dev/null
+++ b/dev-ruby/simplecov/simplecov-0.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code coverage with a configuration library and automatic merging of coverage across test suites"
+HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0.8"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0
+ dev-ruby/simplecov-html:0.8
+ >=dev-ruby/docile-1.1.0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec
+ dev-ruby/shoulda
+ dev-ruby/test-unit:2
+ dev-util/cucumber
+ dev-util/aruba
+ dev-ruby/capybara
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' test/helper.rb features/support/env.rb || die
+
+ # Avoid currently failing test, needs further research.
+ rm test/test_merge_helpers.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+
+# ${RUBY} -S cucumber features || die
+}