summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-28 07:49:11 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-28 07:49:11 +0200
commit1c2007b3af8edad16b40aef45b4ede9e26adda38 (patch)
treef45ed62e5593489eb6bbdeb5454635c4c85d3d8e /dev-ruby/slop
parentdev-ruby/slop: drop 4.8.1, 4.8.2 (diff)
downloadgentoo-1c2007b3af8edad16b40aef45b4ede9e26adda38.tar.gz
gentoo-1c2007b3af8edad16b40aef45b4ede9e26adda38.tar.bz2
gentoo-1c2007b3af8edad16b40aef45b4ede9e26adda38.zip
dev-ruby/slop: add 4.9.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/slop')
-rw-r--r--dev-ruby/slop/Manifest1
-rw-r--r--dev-ruby/slop/slop-4.9.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 2fac4c8e76e1..39ddb4f0416f 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1 +1,2 @@
DIST slop-4.9.1.tgz 16455 BLAKE2B 5d66e1a03b69ac9bbc272c20adbe0daa1a086abf8651838a59c74bde6ff4e136c6b1e10c2266a96508ed333a0f752ace98f95a223464efef2ecea7eeededb024 SHA512 3211b876b910b76413d9109ea7ab400429fb350089a3d89a56b85894a556d0c278daea258551c355a96d9ec592bc7426d9461b7a3fed935c9917e9c18069e89f
+DIST slop-4.9.2.tgz 16633 BLAKE2B 8907314016066569279dbab6b52f50cee58044b46c1a88c7cfab3a31e1bd7e702f63da170a42f113c5611080d5d212b970dddd1e3aeb2bc8e86d5ea577b9f163 SHA512 dbecbc5edaf257131edf54fb5577531a962a6ed64f9414342b5060bee479cf7e4c9cfb891af3553644fbe7817a2067de3c83b379651a62da5983f0c42cd68fd6
diff --git a/dev-ruby/slop/slop-4.9.2.ebuild b/dev-ruby/slop/slop-4.9.2.ebuild
new file mode 100644
index 000000000000..adc818e81c51
--- /dev/null
+++ b/dev-ruby/slop/slop-4.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}