summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-16 07:40:24 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-16 07:59:38 +0200
commitf0ed5b5456e5c195b79da21b42727b70e9a653e1 (patch)
tree328299a935e68aae91afc22e26ec360987a53731 /dev-ruby/spy/spy-0.4.3.ebuild
parentdev-ruby/pry: drop ruby19 (diff)
downloadgentoo-f0ed5b5456e5c195b79da21b42727b70e9a653e1.tar.gz
gentoo-f0ed5b5456e5c195b79da21b42727b70e9a653e1.tar.bz2
gentoo-f0ed5b5456e5c195b79da21b42727b70e9a653e1.zip
dev-ruby/spy: add 0.4.3
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/spy/spy-0.4.3.ebuild')
-rw-r--r--dev-ruby/spy/spy-0.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/spy/spy-0.4.3.ebuild b/dev-ruby/spy/spy-0.4.3.ebuild
new file mode 100644
index 000000000000..e0aa0ba0d270
--- /dev/null
+++ b/dev-ruby/spy/spy-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A simple opinionated mocking framework"
+HOMEPAGE="https://github.com/ryanong/spy"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:0
+ dev-ruby/pry )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/pry-nav/d" -e "/[Cc]overalls/d" Rakefile test/test_helper.rb || die
+}