summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-29 16:30:57 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-29 16:39:24 -0400
commit724fd4202c33ce316aa84251d40ce98a8b87f36f (patch)
tree9032965e047292a4b9c2b0da97c1b3afb40b3e46 /dev-ruby/sshkey/sshkey-1.8.0.ebuild
parentdev-ruby/metasploit-payloads: bump and minor cleanup (diff)
downloadgentoo-724fd4202c33ce316aa84251d40ce98a8b87f36f.tar.gz
gentoo-724fd4202c33ce316aa84251d40ce98a8b87f36f.tar.bz2
gentoo-724fd4202c33ce316aa84251d40ce98a8b87f36f.zip
dev-ruby/sshkey: initial ebuild, dep for metasploit
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/sshkey/sshkey-1.8.0.ebuild')
-rw-r--r--dev-ruby/sshkey/sshkey-1.8.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/sshkey/sshkey-1.8.0.ebuild b/dev-ruby/sshkey/sshkey-1.8.0.ebuild
new file mode 100644
index 000000000000..22df03ecdc5d
--- /dev/null
+++ b/dev-ruby/sshkey/sshkey-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSH private and public key generator in pure Ruby"
+HOMEPAGE="https://rubygems.org/gems/sshkey"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test"