summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-26 09:18:56 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-26 09:20:02 +0200
commit7aadfdc10ba230aa458a070549dbfe5a7abaa075 (patch)
treeea9ce29b48a5131c77a4207f05a86793733705de /dev-ruby/strptime/strptime-0.2.5.ebuild
parentdev-ruby/spy: add 1.0.1 (diff)
downloadgentoo-7aadfdc10ba230aa458a070549dbfe5a7abaa075.tar.gz
gentoo-7aadfdc10ba230aa458a070549dbfe5a7abaa075.tar.bz2
gentoo-7aadfdc10ba230aa458a070549dbfe5a7abaa075.zip
dev-ruby/strptime: add 0.2.5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/strptime/strptime-0.2.5.ebuild')
-rw-r--r--dev-ruby/strptime/strptime-0.2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/strptime/strptime-0.2.5.ebuild b/dev-ruby/strptime/strptime-0.2.5.ebuild
new file mode 100644
index 000000000000..69d7704d293e
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/strptime extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/strptime V=1
+ cp ext/strptime/strptime$(get_modname) lib/strptime/ || die
+}