summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-22 08:52:54 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-22 08:55:53 +0200
commite9e4d92e69a1e6a9e2a15642ab254a67edd5d1d3 (patch)
tree47099aa017310a5819e991ab4de0f3894d1e3ccb /dev-ruby/strptime
parentdev-ruby/state_machine: enable ruby31 (diff)
downloadgentoo-e9e4d92e69a1e6a9e2a15642ab254a67edd5d1d3.tar.gz
gentoo-e9e4d92e69a1e6a9e2a15642ab254a67edd5d1d3.tar.bz2
gentoo-e9e4d92e69a1e6a9e2a15642ab254a67edd5d1d3.zip
dev-ruby/strptime: update EAPI 7 -> 8, add ruby31
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/strptime')
-rw-r--r--dev-ruby/strptime/strptime-0.2.5-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/strptime/strptime-0.2.5-r2.ebuild b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..bec5f0bd8e88
--- /dev/null
+++ b/dev-ruby/strptime/strptime-0.2.5-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/strptime/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/strptime
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast strptime/strftime engine which uses VM"
+HOMEPAGE="https://github.com/nurse/strptime"
+SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}