summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-13 06:47:54 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-13 07:47:15 +0200
commit56d7fb972d98167f0a9cd7a5fdd1069d02f711bb (patch)
tree7803f7539831f213985def35f83a1f5057688da0 /dev-ruby/temple/temple-0.8.2.ebuild
parentpackage.mask: Last rite net-libs/nacl (diff)
downloadgentoo-56d7fb972d98167f0a9cd7a5fdd1069d02f711bb.tar.gz
gentoo-56d7fb972d98167f0a9cd7a5fdd1069d02f711bb.tar.bz2
gentoo-56d7fb972d98167f0a9cd7a5fdd1069d02f711bb.zip
dev-ruby/temple: add 0.8.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/temple/temple-0.8.2.ebuild')
-rw-r--r--dev-ruby/temple/temple-0.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/temple/temple-0.8.2.ebuild b/dev-ruby/temple/temple-0.8.2.ebuild
new file mode 100644
index 000000000000..67120bc22174
--- /dev/null
+++ b/dev-ruby/temple/temple-0.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES EXPRESSIONS.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An abstraction and a framework for compiling templates to pure Ruby"
+HOMEPAGE="https://github.com/judofyr/temple"
+
+LICENSE="MIT"
+SLOT="0.7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bacon
+ dev-ruby/erubis
+ >=dev-ruby/tilt-2.0.1 )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Ilib -Itest --automatic --quiet || die
+}