summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-09-20 07:49:41 +0200
committerHans de Graaff <graaff@gentoo.org>2021-09-21 07:08:34 +0200
commitac176ed4dfbc1ef8b8d22c02a5bcefe941b21dbd (patch)
treeba3e8a47449b37244b4411bb355517a35c04dd0c /dev-ruby/test-unit/test-unit-3.4.0.ebuild
parentdev-ruby/test-unit: add 3.4.7 (diff)
downloadgentoo-ac176ed4dfbc1ef8b8d22c02a5bcefe941b21dbd.tar.gz
gentoo-ac176ed4dfbc1ef8b8d22c02a5bcefe941b21dbd.tar.bz2
gentoo-ac176ed4dfbc1ef8b8d22c02a5bcefe941b21dbd.zip
dev-ruby/test-unit: cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/test-unit/test-unit-3.4.0.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-3.4.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.4.0.ebuild b/dev-ruby/test-unit/test-unit-3.4.0.ebuild
deleted file mode 100644
index 805bffe784ad..000000000000
--- a/dev-ruby/test-unit/test-unit-3.4.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-
-LICENSE="|| ( Ruby GPL-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/power_assert"
-
-all_ruby_prepare() {
- mv doc doc-install || die "moving doc directory out of the way failed"
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb-3 testrb-2
-}