summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-27 10:17:24 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-27 10:22:11 +0100
commit07f747b7838b656bcee54975eb57c3c7e41d0af0 (patch)
tree0bb2f94dcdd6a0dc192e8f2cf63c2a664a475dbd /dev-ruby/test-unit
parentdev-ruby/minitest: add ruby23 (diff)
downloadgentoo-07f747b7838b656bcee54975eb57c3c7e41d0af0.tar.gz
gentoo-07f747b7838b656bcee54975eb57c3c7e41d0af0.tar.bz2
gentoo-07f747b7838b656bcee54975eb57c3c7e41d0af0.zip
dev-ruby/test-unit: drop ruby19 and add ruby23
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/test-unit-3.1.5-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.1.5-r1.ebuild b/dev-ruby/test-unit/test-unit-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..01c6f4d3a2d8
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.1.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md doc/text/news.md"
+
+inherit ruby-fakegem
+
+# Assume for now that ruby23 is not eselected yet and only
+# depend on yard for the other ruby implementations. Without this
+# assumption bootstrapping ruby23 won't be possible due to the yard
+# dependency tree.
+USE_RUBY="${USE_RUBY/ruby23/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+
+LICENSE="|| ( Ruby GPL-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}