summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-29 17:03:09 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-29 17:03:09 +0200
commit3bfeb0135a1de8330689fb7c691580338873d91d (patch)
tree78632cdda0d39495b977d15a9da55b35f129f591 /dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild
parentdev-ruby/syslogger: Remove old (diff)
downloadgentoo-3bfeb0135a1de8330689fb7c691580338873d91d.tar.gz
gentoo-3bfeb0135a1de8330689fb7c691580338873d91d.tar.bz2
gentoo-3bfeb0135a1de8330689fb7c691580338873d91d.zip
dev-ruby/test_construct: Add ruby23, remove ~ppc, ~x86
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild')
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild b/dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..fcddd25103f3
--- /dev/null
+++ b/dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.0.8
+ >=dev-ruby/mocha-0.14.0
+ dev-ruby/rspec:3
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}