summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-25 13:13:25 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-26 06:04:34 +0200
commit97d248a40afeec99e2242907f2adfbbee1cd2bc3 (patch)
tree7fb88c91622cd2a6df8ad7583b229ffabc7873a5 /dev-ruby/text-hyphen
parentapp-backup/untangle-https-backup: remove old v0.0.10-r1 ebuild. (diff)
downloadgentoo-97d248a40afeec99e2242907f2adfbbee1cd2bc3.tar.gz
gentoo-97d248a40afeec99e2242907f2adfbbee1cd2bc3.tar.bz2
gentoo-97d248a40afeec99e2242907f2adfbbee1cd2bc3.zip
dev-ruby/text-hyphen: add ruby30
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/text-hyphen')
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
new file mode 100644
index 000000000000..a4f065842ad0
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.4.1-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hyphenates words according to the rules of the language the word is written in"
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.8.0
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '2igem "test-unit", ">= 2.0"' test/test_*.rb || die
+}