summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-20 09:35:23 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-20 09:47:04 +0100
commitcf61716ad0a9e955142dd7b7943f9656453a6586 (patch)
tree52c6ee294bc3a9efda09e9e09d430d0a2b14d894 /dev-ruby/timecop/timecop-0.9.4.ebuild
parentdev-ruby/timecop: add ruby30 (diff)
downloadgentoo-cf61716ad0a9e955142dd7b7943f9656453a6586.tar.gz
gentoo-cf61716ad0a9e955142dd7b7943f9656453a6586.tar.bz2
gentoo-cf61716ad0a9e955142dd7b7943f9656453a6586.zip
dev-ruby/timecop: add 0.9.4
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/timecop/timecop-0.9.4.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.9.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/timecop/timecop-0.9.4.ebuild b/dev-ruby/timecop/timecop-0.9.4.ebuild
new file mode 100644
index 000000000000..b90d03bddd44
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="https://github.com/travisjeffery/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Missing testdep activesupport
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' \
+ -e '/minitest\/rg/ s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
+ # FIXME after activesupport gained ruby22 support
+ rm test/time_stack_item_test.rb || die
+}
+
+each_ruby_test() {
+ for f in test/*_test.rb ; do
+ ${RUBY} -Ilib $f || die
+ done
+}