summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-28 07:40:41 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-28 07:40:41 +0100
commit9102a5e2fe033f86434edcf871dbc9808944e3bb (patch)
treed09bba6faeae796a3aa95cb16bf54c241b027a4e /dev-ruby/timers/timers-4.1.2.ebuild
parentdev-ruby/power_assert: add 0.4.1 (diff)
downloadgentoo-9102a5e2fe033f86434edcf871dbc9808944e3bb.tar.gz
gentoo-9102a5e2fe033f86434edcf871dbc9808944e3bb.tar.bz2
gentoo-9102a5e2fe033f86434edcf871dbc9808944e3bb.zip
dev-ruby/timers: add 4.1.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/timers/timers-4.1.2.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/timers/timers-4.1.2.ebuild b/dev-ruby/timers/timers-4.1.2.ebuild
new file mode 100644
index 000000000000..3e47ae421983
--- /dev/null
+++ b/dev-ruby/timers/timers-4.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/tarcieri/timers"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/hitimes"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/coveralls/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/Coveralls/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove performance spec due to dependencies and being to dependent
+ # on machine specifics.
+ rm spec/performance_spec.rb
+
+ # Remove rspec3 configuration so we can still run with rspec2.
+ sed -e '/expose/ s:^:#:' -i spec/spec_helper.rb || die
+}