summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-14 07:15:26 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-14 07:15:26 +0100
commit8ff72e410f7f60f3709608665c17825d063bf88a (patch)
tree35375b2ccd4601b951cbd0820d0e4e64238cc268 /dev-ruby/timers/timers-4.3.3.ebuild
parentdev-ruby/activeldap: add 6.1.0 (diff)
downloadgentoo-8ff72e410f7f60f3709608665c17825d063bf88a.tar.gz
gentoo-8ff72e410f7f60f3709608665c17825d063bf88a.tar.bz2
gentoo-8ff72e410f7f60f3709608665c17825d063bf88a.zip
dev-ruby/timers: add 4.3.3
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/timers/timers-4.3.3.ebuild')
-rw-r--r--dev-ruby/timers/timers-4.3.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/timers/timers-4.3.3.ebuild b/dev-ruby/timers/timers-4.3.3.ebuild
new file mode 100644
index 000000000000..fe52c2bb6f01
--- /dev/null
+++ b/dev-ruby/timers/timers-4.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="timers.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/tarcieri/timers"
+SRC_URI="https://github.com/tarcieri/timers/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/covered/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid performance specs to avoid ruby-prof dependency and
+ # because we cannot provide a good environment for performance testing.
+ rm -f spec/timers/performance_spec.rb || die
+}