summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-06-06 17:53:54 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-06-11 14:49:25 -0600
commiteffd69d76799e129ca0c3b4cc6b4601ae366caa2 (patch)
tree0ed98fc9899f887dcd2017d2e165da11481950f5 /dev-ruby/travis
parentx11-misc/xdotool: Cleanup due to #261692 (diff)
downloadgentoo-effd69d76799e129ca0c3b4cc6b4601ae366caa2.tar.gz
gentoo-effd69d76799e129ca0c3b4cc6b4601ae366caa2.tar.bz2
gentoo-effd69d76799e129ca0c3b4cc6b4601ae366caa2.zip
dev-ruby/travis: fix deps
Fix #1648 gh Gentoo-bug: 578458 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/travis')
-rw-r--r--dev-ruby/travis/travis-1.8.2-r2.ebuild (renamed from dev-ruby/travis/travis-1.8.2-r1.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-ruby/travis/travis-1.8.2-r1.ebuild b/dev-ruby/travis/travis-1.8.2-r2.ebuild
index 6b1eb288cde3..939013e37a31 100644
--- a/dev-ruby/travis/travis-1.8.2-r1.ebuild
+++ b/dev-ruby/travis/travis-1.8.2-r2.ebuild
@@ -7,6 +7,8 @@ USE_RUBY="ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_GEMSPEC="travis.gemspec"
+
inherit bash-completion-r1 ruby-fakegem
DESCRIPTION="Travis CI Client (CLI and Ruby library) "
@@ -34,6 +36,10 @@ ruby_add_rdepend "
>=dev-ruby/typhoeus-0.6.8
"
+all_ruby_prepare() {
+ sed -i -e '/typhoeus/s/~> 0.6/>= 0.6/' travis.gemspec || die
+}
+
all_ruby_install() {
all_fakegem_install