summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-26 07:52:52 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-26 07:52:52 +0100
commitc1196e672855b20f09f9c448ea50a9f416cca486 (patch)
tree3778bbbfb45b9d5d720754cf0b63faa959dc5122 /dev-ruby/treetop/treetop-1.6.5.ebuild
parentdev-ruby/git: add 1.3.0 (diff)
downloadgentoo-c1196e672855b20f09f9c448ea50a9f416cca486.tar.gz
gentoo-c1196e672855b20f09f9c448ea50a9f416cca486.tar.bz2
gentoo-c1196e672855b20f09f9c448ea50a9f416cca486.zip
dev-ruby/treetop: add 1.6.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/treetop/treetop-1.6.5.ebuild')
-rw-r--r--dev-ruby/treetop/treetop-1.6.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/treetop/treetop-1.6.5.ebuild b/dev-ruby/treetop/treetop-1.6.5.ebuild
new file mode 100644
index 000000000000..d69403ae14cb
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages"
+HOMEPAGE="https://github.com/cjheath/treetop"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.0 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1:0"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}