summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-03 06:55:21 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-03 07:27:55 +0100
commit7c5c6a5f016838cbac57bb3c2f8a9c7efdf4e32d (patch)
tree68fe12c3911351eedaf4ba09c9b722fa017c9981 /dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
parentgames-puzzle/hexamine: Remove last-rited pkg (diff)
downloadgentoo-7c5c6a5f016838cbac57bb3c2f8a9c7efdf4e32d.tar.gz
gentoo-7c5c6a5f016838cbac57bb3c2f8a9c7efdf4e32d.tar.bz2
gentoo-7c5c6a5f016838cbac57bb3c2f8a9c7efdf4e32d.zip
dev-ruby/tty-cursor: add 0.7.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild')
-rw-r--r--dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
new file mode 100644
index 000000000000..db36fec431af
--- /dev/null
+++ b/dev-ruby/tty-cursor/tty-cursor-0.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="tty-cursor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Move the terminal cursor around and manipulate text using intuitive method calls"
+HOMEPAGE="https://github.com/piotrmurach/tty-cursor"
+SRC_URI="https://github.com/piotrmurach/tty-cursor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}