summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-04-18 07:33:52 +0200
committerHans de Graaff <graaff@gentoo.org>2021-04-18 07:34:05 +0200
commit1538ab36e4aa046c33a2de282c3d2d3ba79c7169 (patch)
tree50de1f0dc757484de8c35595f951e36edc71f927 /dev-ruby/tty-prompt
parentdev-ruby/wisper: add ruby30 (diff)
downloadgentoo-1538ab36e4aa046c33a2de282c3d2d3ba79c7169.tar.gz
gentoo-1538ab36e4aa046c33a2de282c3d2d3ba79c7169.tar.bz2
gentoo-1538ab36e4aa046c33a2de282c3d2d3ba79c7169.zip
dev-ruby/tty-prompt: add 0.23.1
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/tty-prompt')
-rw-r--r--dev-ruby/tty-prompt/Manifest1
-rw-r--r--dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/tty-prompt/Manifest b/dev-ruby/tty-prompt/Manifest
index 8c52c279dbc9..06ba7f101e7c 100644
--- a/dev-ruby/tty-prompt/Manifest
+++ b/dev-ruby/tty-prompt/Manifest
@@ -2,3 +2,4 @@ DIST tty-prompt-0.20.0.gem 72704 BLAKE2B c3a24544459bfd70aa1ada029211d8873665794
DIST tty-prompt-0.21.0.tar.gz 72679 BLAKE2B 1693a2ad49d308975c0f03d9bbf01a192bc6e5c66eb04108a08a7d338c79d20ac80e8b45b0833f57b6a4f5191880160a8df0a9b9751c3af1f3d77b4952c99393 SHA512 e2963951523f9077a6aac20d12b88d261902c1f6ab1ab01bafd9eef94df76e37fd1448d5b5f81a3a8d2335eade4618896a64c77e80e369b3a660bc8d361cb53d
DIST tty-prompt-0.22.0.tar.gz 551572 BLAKE2B b18e3acba984c6848161deff659112ee2342d4021c0fa8df1aed1f19d4530382b4c2d4e215b42820be9939a8a563333c163217ac59809b3e9b1e4d68068647eb SHA512 2bc87d41c9359da1bb04a53c2f3535e4845e1a55594624235434b4e6d5f870029ae72436487fa6d2a795101d1fc8263d63dd89cc5d3e59b0756b80448c23e514
DIST tty-prompt-0.23.0.tar.gz 553952 BLAKE2B 32ac89708b89550c0e46e9dd76cc4acbb1a8bdf6a365019e463c30bd60ee0e06a74a7c5b2c4f8f3cbda70f3a37ec86d6b5be788aec5f73411381f6195c13a467 SHA512 c37213f37c33c756e99ac5aa3c6124c25b94d53a72e013ccca31427a4e9bdb05284926cfc89d39b444cbe75946fe64f1ec40ad61e89f9440b946d9d32ce3ca1b
+DIST tty-prompt-0.23.1.tar.gz 554471 BLAKE2B ae39444b80781ee5c85df87f4ec2b2231b4551a23202070c4570d0e4807a3e4465bb026299dd775de9abf2b8cefe3157cb3fc5297cce4d248f6f8e2aca8c572d SHA512 5e2762d2b229f0aadde7fa09e43ccd317dbda057d829c9003fc6b18f9aaacda1416357af733c4e4f308041c8119ef344b3adc1954a6d31abf801cffdb1848a61
diff --git a/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild b/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild
new file mode 100644
index 000000000000..ccd06d3c998e
--- /dev/null
+++ b/dev-ruby/tty-prompt/tty-prompt-0.23.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="tty-prompt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A beautiful and powerful interactive command line prompt"
+HOMEPAGE="https://github.com/piotrmurach/tty-prompt"
+SRC_URI="https://github.com/piotrmurach/tty-prompt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/pastel-0.8:0
+ >=dev-ruby/tty-reader-0.8:0
+"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+ sed -i -e 's:require_relative ":require "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}